Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reporting
Incident Report for Smartsheet
Resolved
Beginning at 7:42 PM Pacific Standard Time (PST) on November 23, 2016, customers using the Smartsheet application may have experienced slowness or errors when attempting to load or save a report.

By 12:42 PM PST on November 24, 2016 a solution for the problem was identified, and we determined system status had returned to normal. We have continued to monitor systems since this time and they have operated as expected.
Posted Nov 24, 2016 - 17:31 PST
Monitoring
We have fixed the issue with Reports for Smartsheet. We are currently monitoring the Smartsheet application to make sure everything is operating normally.
Posted Nov 24, 2016 - 12:44 PST
Investigating
We're currently experiencing technical issues with Reports in Smartsheet. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Nov 24, 2016 - 12:11 PST
This incident affected: Core Application (Reports).