Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
System Generated Emails
Incident Report for Smartsheet
Resolved
On the morning of November 13, 2016 customers using the Smartsheet application may have experienced delays with System Generated emails from Smartsheet.

System health was restored by our Operations team at 11:30 AM Pacific Standard Time and the system has continued to perform as expected since.
Posted Nov 13, 2016 - 19:00 PST
Monitoring
We have fixed an issue causing delays with System Generated emails in Smartsheet. We are currently monitoring the Smartsheet application to make sure everything is operating normally.
Posted Nov 13, 2016 - 12:42 PST