Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Application & API - Degraded Performance
Incident Report for Smartsheet
Resolved
On the morning of December 27th, at 8:17 AM pacific time, some users of the Smartsheet application may have received intermittent error messages or failures when attempting to load or save sheets. We discovered an inefficiency in the manner that our databases were being called in certain situations. Operations and Development were engaged and took action to mitigate the issue returning the service to normal by 10:53 AM pacific time. Additionally, we deployed a code fix the same day, in order to permanently correct this issue.
Posted Dec 29, 2016 - 10:55 PST
Monitoring
The recent technical issue is no longer active. We are currently monitoring the Smartsheet application to make sure everything is operating normally.
Posted Dec 27, 2016 - 11:25 PST
Investigating
The Smartsheet Application is currently experiencing some technical issues. Some users may experience temporary errors when loading or saving sheets. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Dec 27, 2016 - 09:38 PST
This incident affected: Core Application (Sheets).