Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Application & API
Incident Report for Smartsheet
Resolved
At 12:40 PM Pacific Time, users experienced issues creating webhooks. Existing webhook callbacks were also impacted as well as the Connectors platform. The problem was identified and corrected at 1:20 PM Pacific time and the system began processing the backlog of requests. The impacted systems have continued to perform as expected since.
Posted Sep 01, 2016 - 15:36 PDT
Monitoring
We've fixed the recent technical issue with and are currently monitoring to make sure everything is functioning normally.
Posted Sep 01, 2016 - 13:23 PDT
Investigating
The Smartsheet Application is currently experiencing some technical issues. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Sep 01, 2016 - 13:14 PDT
This incident affected: Core Application (Sheets).