Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Application & API
Incident Report for Smartsheet
Resolved
On September 19th at 11:25 AM Pacific Time, users of the Smartsheet application may have experienced intermittent latency or errors when attempting to load or save sheets. Our operations team identified the issue and found that network activity on the up link to our providers had reached a throughput limit.

We have implemented changes to reduce our network utilization and have seen improved performance. We are also building out our infrastructure to continue to provide an excellent customer experience going forward.

Since implementing the enhancements, the systems have continued to function as expected.
Posted Sep 21, 2016 - 15:28 PDT
Monitoring
Some users of the Smartsheet Application may have recently experienced errors while attempting to load and save sheets. The interruption is no longer active and we are investigating. Thanks for your patience.
Posted Sep 19, 2016 - 14:35 PDT
This incident affected: Core Application (Sheets).