Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Informational Update: Notifications of sheet changes being triggered.
Incident Report for Smartsheet
Resolved
Our recent issue affecting notification email has been resolved. The problem was identified and corrected on Monday, August 7th. For the next two weeks we have continued to monitor notification emails and have determined that they are working as expected.
Posted Aug 22, 2016 - 13:27 PDT
Monitoring
With the update to Smartsheet on Saturday August 6th we modified the calculation engine for Smartsheet. The changes included increased precision in how Smartsheet handles numbers and significant improvements in calculation speed and memory usage. As part of the update, the migration to the new engine registered data changes due to the increased precision of calculated values on sheets referenced by cell links. Due to the nature of cell linking this caused the system to generate notification emails indicating sheet changes had occurred.
Posted Aug 07, 2016 - 21:01 PDT
This incident affected: Notifications (Email Notifications).