Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Intermittently Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 15:45 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of the Smartsheet application.
Posted Oct 07, 2020 - 13:42 PDT
Investigating
We are investigating failures logging into Smartsheet for some users and will provide an update within the next 30 minutes.
Posted Oct 07, 2020 - 13:14 PDT
This incident affected: Authentication and Sign In (Smartsheet Login, Single Sign On ( Company Credentials ), Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID).