Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Connectors Maintenance (Connectors remain operational)
Incident Report for Smartsheet
Postmortem

An issue with the navigation buttons leading to the Connectors applications caused a spike in our database CPU usage, resulting in degraded performance. The buttons were removed from the right rail but the connectors remain accessible via direct URL navigation. The team is working towards reinstating the navigation buttons to enable users to access the Connectors functionality, but this will take some time and there is no estimate yet for when they will be reinstated.

Posted May 11, 2022 - 09:35 PDT

Resolved
The Connectors continue to be fully operational, but their in-app button continue to be turned off while we perform maintenance.
Posted May 07, 2022 - 09:51 PDT
Update
We continue to work on the maintenance described below. The Connectors remain fully operational.
Posted Apr 13, 2022 - 15:45 PDT
Update
The Connectors continue to be fully operational, but their in-app button continue to be turned off while we perform maintenance. To access the Connectors, please use the direct URLs:
https://connectors.smartsheet.com/c/jira/login
https://connectors.smartsheet.com/c/salesforce/login
https://connectors.smartsheet.com/c/plugin/Dynamics/login

We will re-enable the in-app button after the maintenance completes, which we expect to take at least a few days.
Posted Apr 12, 2022 - 13:37 PDT
Identified
We've identified backend issues with our service and temporarily disabled navigation UI to the Connectors during this maintenance period. The Connectors icon on the Feature Bar (also known as the right rail hand panel) will not be visible during this time. However this does not impact the Connector's core functionalities or the ability to administrate via each connector's direct URL.
https://connectors.smartsheet.com/c/jira/login
https://connectors.smartsheet.com/c/salesforce/login
https://connectors.smartsheet.com/c/plugin/Dynamics/login

We will provide an update as investigation completes.
Posted Apr 11, 2022 - 10:53 PDT
This incident affected: Connectors (Dynamics Connector, Jira Connector, Salesforce Connector).