Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Connectivity
Incident Report for Smartsheet
Postmortem

A configuration issue resulted in connectivity issues and caused some users to be unable to reach the Smartsheet application. A fix to the configuration issue was identified and implemented, restoring access to the Smartsheet application for all users.

Posted Apr 15, 2022 - 17:04 PDT

Resolved
This incident has been resolved.
Posted Apr 14, 2022 - 20:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results for further stability.
Posted Apr 14, 2022 - 18:00 PDT
Identified
The issue has been identified and a fix is being implemented. We will provide an update in 30 minutes.
Posted Apr 14, 2022 - 17:56 PDT
Investigating
We are currently investigating customer reports of Smartsheet connectivity issues. We will provide an update in 30 minutes.
Posted Apr 14, 2022 - 17:36 PDT
This incident affected: Authentication and Sign In (Smartsheet Login).