Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to access connectors
Incident Report for Smartsheet
Resolved
The Smartsheet Application has remained stable since our engineers took action to mitigate the issue. The issue has been resolved, and we are closing this incident
Posted Oct 17, 2018 - 11:58 PDT
Monitoring
Our Salesforce and Jira connectors experienced an issue for approximately 15 minutes. During this time, users were unable to sign into the connectors and workflows didn't process.
Posted Oct 16, 2018 - 11:17 PDT
This incident affected: Connectors (Jira Connector).