Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reports of Slow Loading in Smartsheet App
Incident Report for Smartsheet
Postmortem

On June 23rd, between 1:07pm and 1:18pm some customers experienced that the Smartsheet app was slow to load. Our team implemented a fix and the issue was resolved.

Posted Jun 27, 2023 - 21:52 PDT

Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 15:33 PDT
Monitoring
We have identified an issue where users may have experienced slow load times. We are monitoring the service to ensure recovery.
Posted Jun 23, 2023 - 13:33 PDT
This incident affected: Core Application (Sheets, Reports, Dashboards).