Smartsheet Logo

Smartsheet Status

 
Unable to Load Reports
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 14, 2021 - 15:11 PDT
Monitoring
We have identified the issue where some users may have experienced issues loading some reports and on dashboards. Our team has taken action to resolve this. The service is recovering and we will continue to monitor.
Posted Jul 14, 2021 - 13:14 PDT
This incident affected: Core Application (Reports).