Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reports are not loading
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 19:36 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Oct 27, 2022 - 17:39 PDT
Investigating
We are currently investigating an issue where some customers are unable to load reports.
Posted Oct 27, 2022 - 17:09 PDT
This incident affected: Core Application (Reports).