Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to Access Admin Center
Incident Report for Smartsheet
Postmortem

On 1/5/22 Admin Center was unavailable from 9:40 -10:05 PST. A change implemented impacted the availability of the experience including authentication into the service. The change was rolled back around 10:03 with service being restored immediately. During this process, the Admin Center was intermittently available to different users depending on their current logged-in status.

Posted Feb 18, 2022 - 08:42 PST

Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 12:22 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2022 - 10:13 PST
Investigating
We are currently investigating some customer reports of not being able to access Admin Center. System Admins can continue to manage their Smartsheet account by navigating to the "Plan and Billing Info" section in Smartsheet app. We will provide an update in 60 minutes.
Posted Jan 05, 2022 - 10:05 PST
This incident affected: Administration and Audit (Admin Center).