Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Sheet link delay
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Feb 21, 2019 - 23:08 PST
Monitoring
The backlog of cell link updates has fully recovered. We are monitoring to ensure continued stability of this feature.
Posted Feb 21, 2019 - 19:15 PST
Identified
We have identified the cause of these cell link delays and have implemented a fix. The backlog of cell link updates is quickly recovering.
Posted Feb 21, 2019 - 18:35 PST
Update
We are continuing to investigate delays in sheet links. Further updates will be posted as status changes.
Posted Feb 21, 2019 - 18:00 PST
Update
We are continuing to investigate delays in sheet links.
Posted Feb 21, 2019 - 17:19 PST
Investigating
Cell link processing is currently delayed. We are investigating and will provide an update within the next 30 minutes.
Posted Feb 21, 2019 - 16:38 PST
Monitoring
The backlog of cell link updates is fully recovered. We are monitoring to ensure continued stability of this feature.
Posted Feb 21, 2019 - 15:19 PST
Identified
We believe to have identified the cause of these cell link delays and have implemented a fix. The backlog of cell link updates is recovering; we expect to be caught up within the next two hours.
Posted Feb 21, 2019 - 14:50 PST
Update
We're continuing to investigate delays in sheet links.
We've isolated the issue and confirmed this is only impacting sheets with cell links.
Posted Feb 21, 2019 - 14:01 PST
Update
We are continuing to investigate delays in sheet links.
Posted Feb 21, 2019 - 13:00 PST
Investigating
Our monitoring systems have detected a possible delay in sheet link updates. We are investigating and will provide an update within the next 30 minutes.
Posted Feb 21, 2019 - 12:32 PST
This incident affected: Core Application (Sheets).