Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Forms unavailable
Incident Report for Smartsheet
Postmortem

On April 4th, 2023 at 2:57pm PT, we received reports that users were unable to open Forms. An internal process caused a database to throttle traffic. Users were unable to view or save a Form between 2:57pm and 3:11pm PT. Our engineers were able to fully restore fully the Forms functionality at 3:15pm.

Posted Apr 05, 2023 - 10:13 PDT

Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 15:52 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Apr 04, 2023 - 15:24 PDT
Investigating
We are currently investigating some customer reports of being unable to load forms. We will provide an update in 60 minutes.
Posted Apr 04, 2023 - 15:15 PDT
This incident affected: Core Application (Forms).