Smartsheet Logo
Intermittent access issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 11, 2020 - 06:00 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 11, 2020 - 05:59 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jul 10, 2020 - 05:55 PDT
Investigating
We are investigating intermittent access issues with Smartsheet, and will provide an update within the next 30 minutes.
Posted Jul 10, 2020 - 05:51 PDT
This incident affected: Core Application (Sheets).