Smartsheet Logo
Issues with Forms
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 10:50 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Oct 15, 2020 - 08:51 PDT
Investigating
We are currently investigating reports of issues with forms. We will provide an update in 30minutes
Posted Oct 15, 2020 - 08:20 PDT
This incident affected: Core Application (Forms).