Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Inbound Sheet Link Delay
Incident Report for Smartsheet
Resolved
The issue has been resolved.
Posted Jun 28, 2018 - 23:17 PDT
Update
The Sheet Link functionality within Smartsheet is now up to date. The delay issue has ended and no further impact has been observed. We are continuing to monitor.
Posted Jun 28, 2018 - 18:35 PDT
Monitoring
Our engineering team has identified and made configuration changes to resolve the issue. The Sheet Links are delayed by approximately one hour. Processing is expected to be caught up in one hour.
Posted Jun 28, 2018 - 15:18 PDT
Investigating
Inbound Sheet Links are currently delayed about 2.5 hours. Our engineers are currently investigating the issue.
Posted Jun 28, 2018 - 12:26 PDT
This incident affected: Core Application (Sheets).