Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Google Auth login issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Aug 20, 2019 - 01:05 PDT
Monitoring
Google has resolved the issue with their authentication service. Smartsheet users should no longer experience issues logging into Smartsheet using the Google sign-in option.
We are monitoring to ensure continued stability of this feature.
Posted Aug 19, 2019 - 13:43 PDT
Update
Workaround: Some customers have reported success attempting to utilize an incognito Chrome window to login.
Posted Aug 19, 2019 - 12:29 PDT
Investigating
We are aware of users failing login into Smartsheet using the Google sign-in option. Google is currently experiencing a service issue with their authentication service, https://status.cloud.google.com/incident/developers-console/19008
Posted Aug 19, 2019 - 12:07 PDT
This incident affected: Core Application (Sheets).