Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Components Intermittently Unavailable
Incident Report for Smartsheet
Postmortem

At 10:05 AM PST on 3/6/24 there were initial customer reports of issues with Dashboards loading, Form submissions, Workflows, and Notifications. Further customer reports included Admin Center and Control Center. Following further investigation, the engineering team identified that a Datadog service outage at around 10 AM PST impacted our feature functionality. At 11:42 AM PST on 3/6/24 the issue was addressed by reloading the affected features once the Datadog issue was resolved. The team then continued monitoring all affected features for stability and performance until 2:02 PM PST on 3/6/24 when the issue was resolved.

Posted Mar 06, 2024 - 14:22 PST

Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 14:02 PST
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of all affected features.
Posted Mar 06, 2024 - 12:08 PST
Identified
We've identified the issue and are working to resolve it. Forms and workflows are now operational. Dashboards, Notifications, Admin Center, and SCC are still experiencing issues. We will provide an update in 30 minutes.
Posted Mar 06, 2024 - 11:42 PST
Update
We are currently investigating some customer reports of unavailable dashboards, form submissions intermittently failing, users unable to save workflows and notifications not working as intended. We will provide an update in 30 minutes.
Posted Mar 06, 2024 - 11:06 PST
Investigating
We are currently investigating some customer reports of dashboard unavailable, form submissions intermittently failing, users unable to save workflows and notifications not working as intended. We will provide an update in 60 minutes.
Posted Mar 06, 2024 - 10:37 PST
This incident affected: Workflows (In App Workflows), Administration and Audit (Admin Center), Premium Apps (Control Center), Notifications (In App Notifications), and Core Application (Forms, Dashboards).