Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to access Smartsheet
Incident Report for Smartsheet
Postmortem

On September 10th, 2024, at 5:07 PM PST, users were unable to access Smartsheet for 20 minutes. A fix was applied at 5:34 PM PST, customers may have experienced brief slowness across the app until full service was restored at 6:03 PM PST. We are implementing improvements based on the insights gained from this incident to help prevent similar issues in the future.

Posted Sep 12, 2024 - 09:35 PDT

Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 20:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2024 - 18:04 PDT
Investigating
We are aware of the issue with the inability to access Smartsheet. We are currently investigating and will continue to provide updates every 30 minutes and will send another notification to subscribers with the next functional update.
Posted Sep 10, 2024 - 17:24 PDT
This incident affected: Core Application (Smartsheet Login, Single Sign On ( Company Credentials ), Sheets, Forms, Reports, Dashboards).