Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Issues Downloading Attachments from Embedded Sources in Smartsheet Dashboards
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 17, 2020 - 10:35 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2020 - 09:29 PDT
Identified
A fix has been prepared and will be included in our next release. This impacts Chrome browser version 83 only. Older versions of Chrome and other browsers are not affected and are operating as expected.
Posted Jun 05, 2020 - 14:52 PDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2020 - 14:15 PDT
Investigating
Investigating reports of customers using Chrome browser version 83 experiencing issues downloading attachments from sources embedded in Smartsheet dashboards. Older versions of Chrome and other browsers are not effected and are operating as expected.

We will provide an update in the next 30 minutes.
Posted Jun 05, 2020 - 14:15 PDT
This incident affected: Core Application (Sheets).