Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Login and performance issues reported for Control Center
Incident Report for Smartsheet
Postmortem

On May 26th, a database configuration issue caused Control Center to be intermittently available from 12:57 pm PDT to 5:45 pm PDT. We fixed the issue and Control Center is available again.

Posted Jun 09, 2022 - 06:30 PDT

Resolved
This incident has been resolved.
Posted May 26, 2022 - 20:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2022 - 17:51 PDT
Update
The engineering team is engaged and we are investigating intermittent login and performance issues. We will provide an update in 60 minutes.
Posted May 26, 2022 - 17:26 PDT
Update
The engineering team is engaged and we are investigating intermittent login and performance issues. We will provide an update in 60 minutes.
Posted May 26, 2022 - 16:14 PDT
Investigating
The engineering team is engaged and we are investigating intermittent login and performance issues. We will provide an update in 60 minutes.
Posted May 26, 2022 - 15:15 PDT
Identified
The issue has been identified and a fix is being implemented. We will provide an update in 60 minutes.
Posted May 26, 2022 - 14:18 PDT
Investigating
The engineering team is engaged and we are investigating intermittent login and performance issues. We will provide an update in 60 minutes.
Posted May 26, 2022 - 13:35 PDT
This incident affected: Premium Apps (Control Center).