Smartsheet Logo

Smartsheet Status

 
Workflow automation delays for integrated services
Incident Report for Smartsheet
Postmortem

On May 12 at 17:38 UTC, a delay in Bridge caused delays in Bridge Messaging Workflows and automated alerts in the core application with integrated services such as Slack, Google Chat, and Microsoft Teams. During this incident all messaging integrations experienced message delivery delays between Smartsheet and the respective integrated products. No data loss was identified or reported.

Over that period of time, a specific type of traffic caused a part of our Bridge product to be inoperable. Once the traffic returned to normal, everything started processing again. After investigation into the root cause over the days after the incident, steps have now been taken so that similar traffic will not cause issues with Bridge in future. The issue was declared resolved at 18:47 UTC. 

We continue to prioritize investments to scale our networking, compute, security, and other infrastructure, as well as our technical management processes that enable us to consistently deliver great experiences for our customers. 

While we cannot promise a future free of any technical challenges, we promise that we will do whatever it takes to ensure that Smartsheet is a partner that can be counted on to deliver. We know that your success—and your continued trust in Smartsheet—depends on it.

Posted Jun 09, 2021 - 11:34 PDT

Resolved
This incident has been resolved.
Posted May 13, 2021 - 04:06 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted May 13, 2021 - 02:04 PDT
Update
We are currently investigating intermittent delays for Bridge Messaging Workflows and automated alerts in the core application with integrated services such as Slack, Google Chat, and Microsoft Teams. We will provide updates as we learn more.
Posted May 12, 2021 - 11:25 PDT
Investigating
The issue has returned. We are re-investigating delays for Bridge Messaging Workflows and automated alerts in the core application with integrated services such as Slack, Google Chat, and Microsoft Teams. We will provide an update in 30 minutes.
Posted May 12, 2021 - 10:49 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted May 12, 2021 - 10:29 PDT
Investigating
We are currently investigating delays for Bridge Messaging Workflows and automated alerts in the core application with integrated services such as Slack, Google Chat, and Microsoft Teams. We will provide an update in 30 minutes.
Posted May 12, 2021 - 10:13 PDT
This incident affected: Workflows (In App Workflows, Bridge by Smartsheet).