Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Search, Update Requests, and Approval Requests Delays
Incident Report for Smartsheet
Resolved
This issue has been resolved.
After further review, this event had extended impact to the Update and Approval request features. Users may have noticed delayed update and/or approval requests between 8:00 - 10:00am PST.
Posted Feb 08, 2019 - 11:11 PST
Monitoring
Search performance is quickly recovering. We will continue monitoring this.
Posted Feb 08, 2019 - 10:51 PST
Investigating
We're currently experiencing some delay issues with the search functionality in Smartsheet. We're aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Feb 08, 2019 - 10:36 PST
This incident affected: Core Application (Search).