Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Some Smartsheet Generated Emails Not Being Received
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 14:47 PDT
Monitoring
The cause of this issue has been identified and we are continuing to monitor. If you are still experiencing issues with receiving emails from Smartsheet, please check your spam filter.
Posted Oct 29, 2019 - 15:38 PDT
Investigating
We are currently investigating an issue where Smartsheet generated email is not being received by some users. We will provide an update in 30 minutes
Posted Oct 29, 2019 - 14:44 PDT
This incident affected: Notifications (Email Notifications).