Smartsheet Logo

Smartsheet Status

 
 
The Smartsheet Pivot Application was Unavailable for Some Users for a Short Period of Time
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 13:29 PDT
Monitoring
Approximately between 10:43am and 11:15am Pacific some users reported getting errors while attempting to access the Smartsheet Pivot Application. A fix has been implemented and we are monitoring to ensure continued stability of the service.
Posted Sep 08, 2021 - 11:28 PDT
This incident affected: Premium Apps (Pivot).