Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Login attempts failures

Incident Report for Smartsheet

Postmortem

On April 8th, 2025, starting around 6:10 AM PDT, some users experienced issues logging into and navigating Smartsheet. This was confirmed fully resolved for all users by 7:19 AM PDT. Our engineering teams quickly identified that a recent internal service deployment experienced an unexpected failure, impacting login methods and some application features. A rollback of this deployment was initiated, and full service was restored by approximately 7:19 AM PDT. We are reviewing our deployment processes and internal service dependencies to prevent future occurrences.

Posted Apr 08, 2025 - 11:18 PDT

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 07:27 PDT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 07:07 PDT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 07:02 PDT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 07:00 PDT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 06:59 PDT

Investigating

We're investigating issues affecting some login attempts, as well as navigation within the app for logged-in users. The issue has been identified and we're working to mitigate impact.
Posted Apr 08, 2025 - 06:58 PDT
This incident affected: Core Application (Smartsheet Login, Single Sign On ( Company Credentials )) and Third Party Sign In (Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID).