Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Users may experience issues Log in and opening assets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 17 days ago. Jan 27, 2025 - 18:55 PST
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted 17 days ago. Jan 27, 2025 - 16:55 PST
Investigating
Users may experience issues Log in and opening assets.
Our team is actively investigating this issue and working to identify the root cause. We apologize for any inconvenience this may cause and appreciate your patience as we work toward a resolution.
Posted 17 days ago. Jan 27, 2025 - 16:35 PST
This incident affected: Core Application (Smartsheet Login, Single Sign On ( Company Credentials ), Sheets, Reports, Dashboards).