Smartsheet Logo
Intermittent Grid Access
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 23:59 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2019 - 22:08 PST
Identified
The cause of this issue has been identified and a fix is being implemented. We will provide an update in 30 minutes.
Posted Nov 27, 2019 - 21:35 PST
Investigating
Customers may experience intermittent failure in accessing some sheets, We are working to resolve the issue and expect resolution shortly. All Smartsheet services remain available.

We will provide an update within the next 30 minutes.
Posted Nov 27, 2019 - 21:05 PST
This incident affected: Smartsheet Application (Mobile/API, Web Application).