Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Messaging App Delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 09:08 PST
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Nov 20, 2020 - 07:08 PST
Investigating
We are investigating delays of automated notifications to Slack, MS Teams, Workplace, and Google Hangouts. We will provide an update in 30 minutes.
Posted Nov 20, 2020 - 06:55 PST
This incident affected: Notifications (Messaging App Notifications).