Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Web Application Outage
Incident Report for Smartsheet
Resolved
This morning, August 11th at 7:00 AM PDT, users of the Smartsheet application experienced issues logging in to the application and were unable to load or save sheets. Our Operations team was engaged and made a configuration change rate limiting the number of messages processed asynchronously; the change mitigated the issue and the application was brought back online by 7:47 AM PDT. We have continued to monitor our systems since that time and they have operated as expected.
Posted Aug 11, 2017 - 16:58 PDT
Monitoring
We've fixed the recent technical issue and are currently monitoring the Smartsheet application to make sure everything is operating normally
Posted Aug 11, 2017 - 07:46 PDT
Update
We are continuing to investigate the the issues with the Smartsheet Application. The Smartsheet API and Mobile app are functional at this time
Posted Aug 11, 2017 - 07:27 PDT
Investigating
The Smartsheet Application is currently experiencing some technical issues. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Aug 11, 2017 - 07:12 PDT
This incident affected: Core Application (Sheets).