This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
A mitigation is now in place, and we're seeing a strong recovery. We'll continue monitoring closely to confirm the issue is fully resolved.
Posted Aug 11, 2026 - 14:02 PDT
Update
We're continuing to look into this and are working toward a mitigation that we expect to have in place soon.
Posted Aug 11, 2026 - 13:26 PDT
Investigating
We are investigating issues with Sheets, Reports, and Workflows. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.
Posted Aug 11, 2026 - 12:51 PDT
This incident affected: Workflows (In App Workflows) and Core Application (Sheets, Reports).