Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Issues Loading Cell Links
Incident Report for Smartsheet
Postmortem

On Jan 25, 2022 at 5:45 am PDT, some customers experienced read only sheets while opening sheets. The primary issue was that Cell Link Database was experiencing increased CPU load and high query latency due to a large number of concurrent duplicate queries running against it for a specific sheet. When the Cell Link Database experiences high query latency, the sheets are put into read only mode for a degraded experience with a message that tells the customers to refresh the sheet instead of not loading the sheet at all.

We disabled circular reference checks for the specific sheet which was causing the large number of concurrent duplicate queries to run. Cell Link Database latency was reduced as a result of this change and cell link updates during sheet load started processing normally and the issue was resolved on Jan 25, 2022 at 9:29 am PDT.

In order to prevent this issue from occurring again, cell link service will implement the below changes:

  • Optimize the circular reference check algorithm and prevent it from causing a large number of concurrent duplicate queries to run against the Cell Link Database.

We continue to prioritize investments to scale our networking, compute, security, and other infrastructure, as well as our technical management processes that enable us to consistently deliver great experiences for our customers.

While we cannot promise a future free of any technical challenges, we promise that we will do whatever it takes to ensure that Smartsheet is a partner that can be counted on to deliver. We know that your success and your continued trust in Smartsheet depends on it.

Posted Mar 04, 2022 - 12:51 PST

Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 11:32 PST
Monitoring
We’ve implemented a fix and are monitoring the continued stability of the cell links service in Smartsheet.
Posted Jan 25, 2022 - 09:32 PST
Update
We are continuing to investigate this issue. We will provide an update in the next 30 minutes.
Posted Jan 25, 2022 - 08:56 PST
Investigating
We’re currently investigating customer reports of errors when loading sheets with very high numbers of cell links and these sheets becoming temporarily read-only as a result. We will provide an update in the next 30 minutes.
Posted Jan 25, 2022 - 08:18 PST
This incident affected: Core Application (Sheets).