Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Errors Accessing Control Center
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 11:23 PST
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Dec 08, 2020 - 09:21 PST
Update
We are continuing to investigate some user reports of getting an intermittent error message when trying to access Control Center. The Smartsheet application remains up and operational. We will provide an update in 30 minutes.
Posted Dec 08, 2020 - 09:12 PST
Update
We are continuing to investigate some user reports of getting an intermittent error message when trying to access Control Center. The Smartsheet application remains up and operational. We will provide an update in 30 minutes.
Posted Dec 08, 2020 - 08:39 PST
Investigating
We are currently investigating some user reports of getting an intermittent error message when trying to access Control Center. The Smartsheet application remains up and operational. We will provide an update in 30 minutes.
Posted Dec 08, 2020 - 08:09 PST
This incident affected: Premium Apps (Control Center).