Smartsheet Logo
Smartsheet Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 18:31 PST
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Feb 02, 2021 - 16:29 PST
Investigating
We are investigating issues logging into Smartsheet and will provide an update within the next 30 minutes.
Posted Feb 02, 2021 - 16:24 PST
This incident affected: Authentication and Sign In (Smartsheet Login).