Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Some Users Unable to Reach Certain Sheets
Incident Report for Smartsheet
Postmortem

On August 18th, 2021 between 04:30 PM and 07:50 PM PDT, some users were unable to access certain sheets. We determined this was the result of an update and have reverted the changes restoring access on August 18th, 2021 at 07:50 PM PDT.

Posted Aug 18, 2021 - 22:01 PDT

Resolved
This incident has been resolved.
Posted Aug 18, 2021 - 22:00 PDT
Monitoring
A fix has been implemented and affected users should no longer see the issue. We are monitoring to confirm continued stability of the Smartsheet application.
Posted Aug 18, 2021 - 20:01 PDT
Update
We are continuing to investigate some customer reports of the error "Unable to Reach" when attempting to access certain sheets. Other users may be able to reach the sheet without issue. We will provide an update in 30 minutes.
Posted Aug 18, 2021 - 19:36 PDT
Investigating
We are currently investigating some customer reports of the error "Unable to Reach" when attempting to access certain sheets. We will provide an update in 30 minutes.
Posted Aug 18, 2021 - 19:07 PDT
This incident affected: Core Application (Sheets).