Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Services Impacted by Google Cloud Incident
Incident Report for Smartsheet
Postmortem

On November 16, 2021 at 17:45 GMT 45 Bridge workflows failed due to extensions having a dependency which could not access the network load balancer. This was due to the Google Cloud Platform experiencing a network outage at this time period. The exact time period reported by GCP was 1 hour and 49minutes, however Bridge data shows that failed workflows were over a shorter time period of 30 minutes. For those failed workflows, retries will not have been attempted once GCP service was restored.

 The monitoring system wasn’t configured to notify us in case of an event of zero data points coming through and therefore failed to send an alert.  The team were made aware of the issue via alerts from multiple services depending on GCP. Actions have been taken to reconfigure the monitoring, alerting when zero data points are received. Continued work is being made to prioritize and improve the telemetry in extensions, detecting failures sooner.

While we cannot promise a future free of any third party system outages, for the long term solution, we are in the process of migrating Bridge onto AWS which will allow for transparency of the extensions health and improved alerting.

Posted Feb 08, 2022 - 11:34 PST

Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 13:50 PST
Monitoring
Smartsheet features impacted by this incident have recovered and are working as expected.
Posted Nov 16, 2021 - 11:44 PST
Identified
The Google Cloud Platform is currently experiencing issues (https://status.cloud.google.com/incidents/6PM5mNd43NbMqjCZ5REh). This may cause impact to certain Smartsheet functionality.
Posted Nov 16, 2021 - 10:37 PST
This incident affected: Connectors (Dynamics Connector), Workflows (Bridge by Smartsheet), and Notifications (Messaging App Notifications).