Smartsheet Logo
App-generated email delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 30 days ago. Jul 26, 2019 - 09:34 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted about 1 month ago. Jul 25, 2019 - 20:26 PDT
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jul 25, 2019 - 19:32 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jul 25, 2019 - 18:07 PDT
Investigating
Our monitoring systems have detected email delivery delays of app-generated emails such as those generated from automation rules, sheets sent as an attachment, Update and Approval requests.
We are investigating and will provide an update within the next 30 minutes.
Posted about 1 month ago. Jul 25, 2019 - 17:35 PDT
This incident affected: System Generated Emails.