Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reports of customers unable to access Smartsheet
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 15:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2023 - 12:37 PDT
Update
We are currently investigating some customer reports of customers unable to access Smartsheet. We will provide an update in 30 minutes.
Posted Sep 08, 2023 - 11:58 PDT
Investigating
We are currently investigating some customer reports of customers unable to access Smartsheet.
Posted Sep 08, 2023 - 11:23 PDT
This incident affected: Core Application (Sheets, Sharing, Forms, Reports, Dashboards, Search, Mobile App, Conversations, Desktop App).