Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Board View Pop Up
Incident Report for Smartsheet
Postmortem

At 11:10 am PDT on July 24th, 2024, we noticed that users couldn’t exit out of a modal dialog shown on top of sheets to introduce the new Board View. The team applied an initial fix by 12:03 pm but some more instances of the issue were observed starting 12:06 pm. The investigation resumed and the issue was fully resolved by 2:06 pm.

Posted Jul 25, 2024 - 09:09 PDT

Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 14:06 PDT
Monitoring
A fix has been implemented and we are monitoring the service for further stability.
Posted Jul 24, 2024 - 12:03 PDT
Investigating
Users couldn't exit out of a promotional dialog for the new Board View. We have made a change to address this issue. A browser refresh might be needed to resolve the issue. We will provide further updates within 30 minutes.
Posted Jul 24, 2024 - 11:54 PDT
This incident affected: Core Application (Sheets).