Smartsheet Logo
Outlook email delivery issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 20:57 PDT
Monitoring
Earlier today, a small amount of password reset and scheduled notification emails were incorrectly marked as spam by some email providers and were not delivered. A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Apr 22, 2020 - 20:07 PDT
Investigating
We are investigating reports of intermittent email delivery issues for Outlook users.
Posted Apr 22, 2020 - 19:20 PDT
This incident affected: System Generated Emails.