Smartsheet Logo
Intermittent Form Submission Failures
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 10:55 PDT
Monitoring
The Forms service has returned to normal and we are monitoring to ensure the continued stability of this feature.
Posted Aug 24, 2020 - 08:48 PDT
Update
We are continuing to investigate reports of intermittent Form submissions failing for some customers. We will provide an update in the next 30 minutes.
Posted Aug 24, 2020 - 08:11 PDT
Investigating
We are investigating reports of intermittent Form submissions failing for some customers. We will provide an update in the next 30 minutes.
Posted Aug 24, 2020 - 07:40 PDT
This incident affected: Core Application (Forms).