Smartsheet Logo
Slow Forms Performance
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 12, 2019 - 19:18 PDT
Update
We are continuing to investigate a performance issue with Forms.
Posted 3 months ago. Jun 12, 2019 - 18:36 PDT
Investigating
We are currently investigating a performance issue with Forms. Forms with a large number of Drop Down Fields may experience a delay in populating those Drop Down Fields and typed text in Text Fields.
Posted 3 months ago. Jun 12, 2019 - 18:03 PDT
This incident affected: Smartsheet Application (Web Application).