Smartsheet Logo
Error Messages on Sheet Load
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 17:30 PDT
Monitoring
Some users have reported receiving a message that reads, "Smartsheet has experienced an error." This issue has been resolved, and we are taking steps to avoid future interruptions.
Posted Sep 03, 2020 - 15:13 PDT
This incident affected: Core Application (Sheets).