Smartsheet Logo
Account upgrade workflow not functioning as expected
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 15, 2019 - 22:22 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted about 1 month ago. Jul 15, 2019 - 18:04 PDT
Investigating
We are currently investigating an issue with upgrade workflows not loading in-app. If you would like to upgrade your Smartsheet plan, please visit: https://www.smartsheet.com/contact/sales?fts=contact-d
Posted about 1 month ago. Jul 15, 2019 - 17:45 PDT