Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet was Unavailable for Some Users for a Short Period of Time
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 12:34 PDT
Monitoring
Approximately between 9:45am and 10:00am Pacific some users reported getting errors while attempting to use Smartsheet. A fix has been implemented and we are monitoring to ensure continued stability of the service.
Posted Sep 07, 2021 - 10:33 PDT
This incident affected: Core Application (Sheets).