Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Sheet loading delays and errors

Incident Report for Smartsheet

Resolved

This incident has been resolved.
Posted Dec 04, 2024 - 11:23 PST

Monitoring

The issue has been identified and a fix has been implemented.
Posted Dec 04, 2024 - 11:08 PST
This incident affected: Core Application (Sheets, Reports, Dashboards).