Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
We are aware there is a service incident and are investigating the issue
Incident Report for Smartsheet
Resolved
An automation activity which is used to configure DHCP/DNS services misconfigured these services which are critical for the Smartsheet Platform. The SRE and Engineering teams are investigating the root cause and processes which led to this failure in order to prevent this type of error from occurring in the future.
Posted May 31, 2018 - 15:29 PDT
Investigating
Our monitoring system has identified a potential service interruption. We are currently investigating the issue and will provide an update as soon as possible. Please continue to return to this page for the latest resolution status.
Posted May 31, 2018 - 14:32 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).